Студопедия

КАТЕГОРИИ:

АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатикаИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханикаОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторикаСоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансыХимияЧерчениеЭкологияЭкономикаЭлектроника



Вложенные логические функции




Читайте также:
  1. I. Конструктивно-технологические особенности изготовления деталей информационных радиоэлектронных средств (ИРЭС) и обеспечение качества их изготовления
  2. II. НОРМЫ АКЦЕНТОЛОГИЧЕСКИЕ И ОРФОЭПИЧЕСКИЕ
  3. II. Функции
  4. II.ФУНКЦИИ ШКОЛЬНОЙ ФОРМЫ
  5. III. НОРМЫ МОРФОЛОГИЧЕСКИЕ
  6. IV. НОРМЫ ЛЕКСИЧЕСКИЕ И ФРАЗЕОЛОГИЧЕСКИЕ
  7. IV. Функции
  8. IV. Функции
  9. IV. Функции
  10. IV. Функции

Функция ЕСЛИ допускает до 7 уровней вложения в качестве аргументов для конструирования более сложных проверок.

Рис. 12

Пример 3

Надбавка за стаж вычисляется по формуле:

  0, если стаж менее 5 лет;
Надбавка= 10% от оклада, если стаж от 5 до 10 лет;
  20% от оклада, если стаж не менее 10 лет.

Для расчета требуется проверка двух условий, следовательно, необходимо применить вложенную логическую функцию. Такая функция (в ячейке Е3) может выглядеть, например, следующим образом:

=ЕСЛИ(D3<5;0;ЕСЛИ(D3<10;C3*10%;C3*20%))

Функцию можно набрать с клавиатуры или воспользоваться Мастером функций:

1. В ячейке Е3 вызвать функцию ЕСЛИ.

2. В окне аргументов функции заполнить поля двух аргументов:

Рис. 13

3. Перейти в поле третьего аргумента (Значение_если_ложь) и щелкнуть на имени функции в левой части строки формул (там отображается имя функции ЕСЛИ, т.к. эта функция использовалась последней):

4. Откроется новое окно аргументов функции с пустыми полями для ввода вложенной логической функции. Заполнить поля:

Рис. 14

5. Щелкнуть Ok (или нажать <Enter>). В строке формул отобразится вложенная логическая функция

=ЕСЛИ(D3<5;0;ЕСЛИ(D3<10;C3*10%;C3*20%)).

6. Скопировать функцию на нижние ячейки, протянув маркер заполнения.

 


Дата добавления: 2015-09-14; просмотров: 9; Нарушение авторских прав







lektsii.com - Лекции.Ком - 2014-2021 год. (0.007 сек.) Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав
Главная страница Случайная страница Контакты