Студопедия

КАТЕГОРИИ:

АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатикаИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханикаОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторикаСоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансыХимияЧерчениеЭкологияЭкономикаЭлектроника



Функции И, ИЛИ, НЕ.

Читайте также:
  1. II. Функции
  2. II.ФУНКЦИИ ШКОЛЬНОЙ ФОРМЫ
  3. IV. Функции
  4. IV. Функции
  5. IV. Функции
  6. IV. Функции
  7. S:В каких единицах измерения должен быть указан аргумент функции SIN?
  8. Администрация морского порта, ее значение и функции.
  9. Алгоритмы вычисления функции шифрования f и ключей для DES.
  10. Асимптоты графика функции

 

=И(логич. выражение1;логич. выражение2; … )

=ИЛИ(логич. выражение1;логич. выражение2; … )

=НЕ(логич. выражение)

 

Эти функции дают возможность строить сложные логические выражения. Функции И()и ИЛИ()могут иметь в качестве аргументов до 30 логических выражений, функция НЕ()– только один аргумент. Аргументами этих функций могут быть логические значения, массивы, адреса ячеек.

Результаты, получаемые с помощью функций И()и ИЛИ()существенно отличаются.

 

Рассмотрим примеры:

=ЕСЛИ(И(А3>0; B3>0); “Решение есть”; “Решения нет”))

=ЕСЛИ(ИЛИ(А3<0; B3<0); “Решения нет”; “Решение есть”))

 

В первом случае: если исодержимое ячейки А3>0, исодержимое ячейки D3>0, результатом будет “Решение есть”,если содержимое хотя бы одной из ячеек (А3 или В3) <=0, результатом будет - “Решения нет”(рис. 5, 6, 7).

 

Рис.5

Рис. 6

 

Рис.7

 

Примечание. Формулу можно сделать короче, если вместо текстовых констант ввести ссылки на них (рис.8).

 

Рис. 8

 

Во втором случае: если илисодержимое ячейки А3<0, илисодержимое ячейки D3<0, результатом будет “Решения нет”,в противном случае Решение есть(рис.9, 10, 11).

Рис. 9


Рис. 10

 

Рис.11

 

Часто вместо функций И, ИЛИ нагляднее использовать операторы умножения и сложения. Например, рассматриваемые формулы можно записать:

=ЕСЛИ(А3>0*D3>0; “Решение есть”; “Решения нет”))(рис.12)

=ЕСЛИ((А3<0)+(D3<0); “Решения нет”; “Решение есть”))(рис.13).

 

Рис.12

Рис.13

 

Функция НЕ()выдает логическое значение противоположное логическому значению своего аргумента:

=НЕ(А1=А2)эквивалентна =А1<>A2

=НЕ(А1>А2)эквивалентна =А1<=A2

Например

=НЕ(2*2=4) вернет ЛОЖЬ, так как условие 2*2=4 истинно (рис. 14).

=НЕ(2*2=5) вернет ИСТИНА, так как условие 2*2=5 ложно (рис.15).

 

Рис. 14 Рис. 15


Дата добавления: 2015-09-14; просмотров: 6; Нарушение авторских прав


<== предыдущая лекция | следующая лекция ==>
Функции проверки условия | Вложение функций ЕСЛИ()
lektsii.com - Лекции.Ком - 2014-2019 год. (0.01 сек.) Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав
Главная страница Случайная страница Контакты