Студопедия

КАТЕГОРИИ:

АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатикаИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханикаОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторикаСоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансыХимияЧерчениеЭкологияЭкономикаЭлектроника



Вложение функций ЕСЛИ()




Читайте также:
  1. A) отличие от сферы частичных функций личности;
  2. III.Характеристика обобщенных трудовых функций
  3. III.Характеристика обобщенных трудовых функций
  4. А) Для финансирования задач и функций государства и местного самоуправления;
  5. Быстрые клавиши для вызова функций Google Chrome
  6. ВЛОЖЕНИЕ КАПИТАЛА
  7. Все переменные конструктораUserстановятся приватными, так как доступны только через замыкание, из внутренних функций.
  8. Графики функций, построенные точками
  9. Доктор Бреггин добавляет, что существуют доказательства того, что риталин может стать причиной необратимых нарушений и дисфункций в мозге ребенка.

 

Функции ЕСЛИ()могут вкладываться друг в друга. Можно вложить друг в друга в качестве второго и третьего аргументов до 7 функций ЕСЛИ().

=ЕСЛИ(B3=25;"Отлично";ЕСЛИ(И(B3<25;B3>22);"Хорошо";ЕСЛИ(И(B3<=22;B3>19);"Удовлетворительно";"Неудовлетворительно")))

Выполняется функция следующим образом: если число, находящееся в ячейке В3, равно 25, то значением функции будет “Отлично”; иначе – если число, находящееся в ячейке В3меньше 25, но больше 22, то функция примет значение “Хорошо”, иначе – если В3меньше или равно 22и больше 19, функция примет значение “Удовлетворительно”, иначе “Неудовлетворительно” (рис.16, 17, 18).

 

Рис.16

Рис.17

 

Рис.18

 

Следует иметь в виду, что вложенных функций ЕСЛИ() должно быть на единицу меньше, чем возможных вариантов принимаемых значений.

Иногда аргументы логических функций становятся громоздкими, если приходится проверять выполнение одного и того же условия элементами блоков ячеек, например:

=ЕСЛИ(И(А4>=B2;B4>=B2;C4>=B2;D4>=B2;E4>=B2;F4>=B2); “Да”; “Нет”)(рис. 19)

 

Условие можно записать короче, если в аргументе функции использовать блок ячеек:

=ЕСЛИ(И(А4:F4>=B2); “Да”; “Нет”)(рис. 20).

 

Рис. 19

Рис. 20

 

ВОПРОСЫ ДЛЯ САМОКОНТРОЛЯ

1. Какие логические функции вы знаете?

2. Для чего используют логические функции?

3. Синтаксис логических функций?


Дата добавления: 2015-09-14; просмотров: 6; Нарушение авторских прав







lektsii.com - Лекции.Ком - 2014-2021 год. (0.007 сек.) Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав
Главная страница Случайная страница Контакты