Студопедия

КАТЕГОРИИ:

АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатикаИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханикаОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторикаСоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансыХимияЧерчениеЭкологияЭкономикаЭлектроника



Подготовка к решению транспортной задачи в EXCEL.




Читайте также:
  1. I. Задачи настоящей работы
  2. I. Цели и задачи проекта
  3. II. Основные цели и задачи Программы, срок и этапы ее реализации, целевые индикаторы и показатели
  4. II. Упражнения и задачи
  5. II. Упражнения и задачи
  6. II. Упражнения и задачи
  7. II. Цели и задачи проекта
  8. III. Для обеспечения проверки исходного уровня Ваших знаний-умений необходимому, предлагаем решить 2 задачи.
  9. III. Для обеспечения проверки исходного уровня Ваших знаний-умений необходимому, предлагаем решить 2 задачи.
  10. III. Подготовка к защите, защита работы

Для решения задачи средством EXCEL «Поиск решения» необходимо разместить в рабочем листе исходные данные и подготовить поля для размещения условий и результатов решения задачи (выбор ячеек листа произвольный). Таким образом будет создана «Электронная модель транспортной задачи».

На рис. 2.2 приведен пример подготовки данных на рабочем листе EXCEL для решения этой задачи.

 

Рис. 2.2 Пример подготовки размещения данных транспортной задачи для решения в EXCEL.

 

Рекомендуется следующий порядок работы в рабочем листе.

1. Выделить диапазон ячеек:

− для размещения исходной матрицы (A14:E19);

− для размещения матрицы оптимальных перевозок (матрица для размещения результатов после решения задачи) (A4:F9), рекомендуется для наглядности в обе матрицы внести текст пояснений;

2) матрицу исходных данных (A14:E19) заполнить исходными данными таблицы 2.6 (значения ai, bj, cij).

В матрице результата во все ячейки диапазона (B6:E9) внести «1» в качестве исходных значений объемов поставок xij, после решения задачи в этих ячейках будут находиться значения поставок, обеспечивающие минимальные затраты на перевозку груза.

3) ввести в ячейки (В10:Е10) итог поставок по потребителям: в ячейку В10 ввести формулу =СУММ(В6:В9) − итог поставок по 1-му потребителю, скопировать эту формулу в ячейки (С10:Е10);

4) ввести в ячейки (F6:F9) итоги реализации мощности каждого из поставщиков: в ячейку F6 ввести формулу =СУММ(В6:Е6) − итог реализации поставок от 1-го поставщика, скопировать эту формулу в ячейки (F7:F9);

5) выделить ячейку для ввода формулы целевой функции, например В21и ввести формулу =СУММПРОИЗВ(В16:Е19;В6:Е9) −суммарнаястоимость перевозок по всем направлениям.

6) в рабочем окне режима «Поиск решения» указать в качестве ячейки целевой функции В21, при вводе ограниченийделать ссылку на отведенные диапазоны (см. данные таблицы 2.7):

Таблица 2.7

Левая часть ограничения Знак Правая часть ограничения Экономический смысл
(В10:Е10) = (В15:Е15) Спрос потребителей должен быть удовлетворен
(F6:F9) = (А16:А19) Весь груз от поставщиков должен быть вывезен

 

 



После проведенной подготовительной работы можно запустить задачу на выполнение. В результате решения ячейки (В6:Е9)будут заполнены значениями объемов перевозок, которые обеспечивают минимальные суммарные затраты на транспортировку всего груза, а величина затрат выдается в ячейке В21.

Приведенный алгоритм подготовки электронной модели транспортной задачи может быть использован для реализации любых моделей распределительных задач, например задач оптимизации загрузки взаимозаменяемого оборудования.

 

Вопросы по теме

1. Сформулируйте постановку транспортной задачи.

2. Опишите математическую модель задачи прикрепления потребителей к поставщикам.

3. Как решается транспортная задача с нарушенным балансом между спросом и потреблением.

4. Приведите запись формализованной модели транспортной задачи.

5. Приведите пример постановки транспортной задачи в табличной форме при трех поставщиках и пяти потребителях.


Дата добавления: 2014-11-13; просмотров: 28; Нарушение авторских прав





lektsii.com - Лекции.Ком - 2014-2020 год. (0.005 сек.) Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав
Главная страница Случайная страница Контакты